GitHub Advisoryadvisory · npm
GHSA-cqjg-whmm-8gv6 Denial of Service via malformed accept-encoding header in hapi
HIGH
Official page ↗
- Aliases
- CVE-2017-16013
- Ecosystem
- npm
- Packages
- hapi
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• npm hapi: >= 15.0.0, < 16.1.1 → fixed in 16.1.1
Description
Affected versions of `hapi` will crash or lock the event loop when a malformed `accept-encoding` header is recieved.
Recommendation
Update to version 16.1.1 or later.
Related
Alias · CVE (1)
- CVE-2017-16013 hapi is a web and services application framework. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness