GitHub Advisoryadvisory · Maven
GHSA-cqp7-hwm3-cfg7 XSS vulnerability in Jenkins Warnings Next Generation Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2019-1003023
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:warnings-ng
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-30
Affected packages
• Maven io.jenkins.plugins:warnings-ng: < 2.0.0 → fixed in 2.0.0
Description
A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.
Related
Alias · CVE (1)
- CVE-2019-1003023 A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness