GitHub Advisoryadvisory · npm
GHSA-cqr7-78pj-3g7j File Descriptor Leak Can Cause DoS Vulnerability in hapi
HIGH
Official page ↗
- Aliases
- CVE-2014-3742
- Ecosystem
- npm
- Packages
- hapi
- Severity
- High
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• npm hapi: >= 2.0.0, < 2.2.0 → fixed in 2.2.0
Description
Versions 2.0.x and 2.1.x of hapi are vulnerable to a denial of service attack via a file descriptor leak.
When triggered repeatedly, this leak will cause the server to run out of file descriptors and the node process to die. The effort required to take down a server depends on the process file descriptor limit. No other side effects or exploits have been identified.
Recommendation
• Please upgrade to version 2.2.x or above as soon as possible.
Related
Alias · CVE (1)
- CVE-2014-3742 The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3742 advisory
- https://github.com/spumko/hapi/issues/1427 web
- https://github.com/advisories/GHSA-cqr7-78pj-3g7j advisory
- https://github.com/spumko/hapi package
- https://www.npmjs.com/advisories/11 web
- http://www.openwall.com/lists/oss-security/2014/05/13/1 web
- http://www.openwall.com/lists/oss-security/2014/05/15/2 web