GitHub Advisoryadvisory · npm, Maven
GHSA-cr3q-pqgq-m8c2 Spoofing attack in swagger-ui
MEDIUM
Official page ↗
- Aliases
- CVE-2018-25031
- Ecosystem
- npm, Maven
- Packages
- swagger-ui, org.webjars:swagger-ui
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-20, CWE-918, CWE-922
- Reviewed
- 2022-03-14
Affected packages
• npm swagger-ui: < 4.1.3 → fixed in 4.1.3
• Maven org.webjars:swagger-ui: < 4.1.3 → fixed in 4.1.3
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
Related
Alias · CVE (1)
- CVE-2018-25031 Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-25031 advisory
- https://github.com/swagger-api/swagger-ui/issues/4872 web
- https://github.com/swagger-api/swagger-ui/pull/7697 web
- https://github.com/swagger-api/swagger-ui package
- https://github.com/swagger-api/swagger-ui/releases/tag/v4.1.3 web
- https://security.netapp.com/advisory/ntap-20220407-0004 web
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885 web