GitHub Advisoryadvisory · Packagist

GHSA-crcq-pw8h-9xwf Moodle does not provide charset information in HTTP headers

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2014-9059
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.5.9 → fixed in 2.5.9 • Packagist moodle/moodle: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist moodle/moodle: >= 2.7.0, < 2.7.3 → fixed in 2.7.3

Description

lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.

Related

Alias · CVE (1)

  • CVE-2014-9059 lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References