GitHub Advisoryadvisory · Maven

GHSA-crhr-qqj8-rpxc Apache ZooKeeper has improper handling of configuration values

HIGH Published 2026-03-07 Modified 2026-03-09 Official page ↗
Aliases
CVE-2026-24308
Ecosystem
Maven
Packages
org.apache.zookeeper:zookeeper
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-532
Reviewed
2026-03-09

Affected packages

• Maven org.apache.zookeeper:zookeeper: >= 3.9.0, < 3.9.5 → fixed in 3.9.5 • Maven org.apache.zookeeper:zookeeper: >= 3.8.0, < 3.8.6 → fixed in 3.8.6

Description

Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.

Related

Alias · CVE (1)

  • CVE-2026-24308 Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose… vulnerability

Weakness · CWE (1)

  • CWE-532 Insertion of Sensitive Information into Log File weakness

References