GitHub Advisoryadvisory · PyPI
GHSA-crvm-xjhm-9h29 OctoPrint vulnerable to XSS in Action Commands Notification and Prompt
MEDIUM
Official page ↗
- Aliases
- CVE-2025-64187
- Ecosystem
- PyPI
- Packages
- octoprint
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79, CWE-80
- Reviewed
- 2025-11-04
Affected packages
• PyPI octoprint: < 1.11.4 → fixed in 1.11.4
Description
Impact
OctoPrint versions up to and including 1.11.3 are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notification and prompt popups generated by the printer.
An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance.
Patches
The vulnerability will be patched in version 1.11.4.
Workaround
OctoPrint administrators can mitigate the risk by disabling popups:
• for Action Command notifications, uncheck _OctoPrint Settings -> Printer Notifications -> Enable popups_
• for Action Command prompts, set _OctoPrint Settings -> Printer Dialogs -> Enable support -> Never_
It is also strongly recommended to ensure that files being printed originate from trusted sources, and, whenever possible, are sliced with your own slicer.
Credits
This vulnerability was discovered and responsibly disclosed to OctoPrint by Jacopo Tediosi.
Related
Alias · CVE (1)
- CVE-2025-64187 OctoPrint provides a web interface for controlling consumer 3D printers. vulnerability