GitHub Advisoryadvisory · Packagist
GHSA-cv23-q6gh-xfrf WooCommerce has a Cross-Site Scripting (XSS) Vulnerability in checkout & registration forms
MEDIUM
Official page ↗
- Aliases
- CVE-2024-37297
- Ecosystem
- Packagist
- Packages
- woocommerce/woocommerce
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79, CWE-80
- Reviewed
- 2024-06-12
Affected packages
• Packagist woocommerce/woocommerce: >= 8.8.0, < 8.8.5 → fixed in 8.8.5
• Packagist woocommerce/woocommerce: >= 8.9.0, < 8.9.3 → fixed in 8.9.3
Description
Impact
A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session.
The URL content is read through the Sourcebuster.js library and then inserted without proper sanitization to the classic checkout and registration forms.
Patches
```diff
diff --git a/plugins/woocommerce/client/legacy/js/frontend/order-attribution.js b/plugins/woocommerce/client/legacy/js/frontend/order-attribution.js
index 79411e928e1..25eaa721c54 100644
--- a/plugins/woocommerce/client/legacy/js/frontend/order-attribution.js
+++ b/plugins/woocommerce/client/legacy/js/frontend/order-attribution.js
@@ -155,12 +155,16 @@
• but it's not yet supported in Safari.
*/
connectedCallback() {
- let inputs = '';
+ this.innerHTML = '';
+ const inputs = new DocumentFragment();
for( const fieldName of this._fieldNames ) {
- const value = stringifyFalsyInputValue( this.values[ fieldName ] );
- inputs += ``;
+ const input = document.createElement( 'input' );
+ input.type = 'hidden';
+ input.name = `${params.prefix}${fieldName}`;
+ input.value = stringifyFalsyInputValue( ( this.values && this.values[ fieldName ] ) || '' );
+ inputs.appendChild( input );
}
- this.innerHTML = inputs;
+ this.appendChild( inputs );
}
/**
```
Workarounds
Disabling the Order Attribution feature
References
A8C SIRT: p3btAN-2L2-p2 (internal)
Public disclosure: https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0/
Related
Alias · CVE (1)
- CVE-2024-37297 WooCommerce is an open-source e-commerce platform built on WordPress. vulnerability
References
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-cv23-q6gh-xfrf web
- https://nvd.nist.gov/vuln/detail/CVE-2024-37297 advisory
- https://github.com/woocommerce/woocommerce/commit/0e9888305d0cb9557e58f558526ab11cb3bcc4b4 web
- https://github.com/woocommerce/woocommerce/commit/915e32a42762916b745a7e663c8b69a698da8b67 web
- https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0 web
- https://github.com/woocommerce/woocommerce package