GitHub Advisoryadvisory · PyPI
GHSA-cv5c-mh6j-wvp9 hermes-agent has an Incorrect Comparison
LOW
Official page ↗
- Aliases
- CVE-2026-9369
- Ecosystem
- PyPI
- Packages
- hermes-agent
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-697
- Reviewed
- 2026-06-30
Affected packages
• PyPI hermes-agent: < 0.15.0 → fixed in 0.15.0
Description
A security flaw has been discovered in NousResearch hermes-agent 2026.4.23. Affected is the function _discover_dashboard_plugins of the file hermes_cli/web_server.py of the component CLI web-dashboard Interface. Performing a manipulation of the argument HERMES_ENABLE_PROJECT_PLUGINS results in incorrect comparison. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.
Related
Alias · CVE (1)
- CVE-2026-9369 A security flaw has been discovered in NousResearch hermes-agent 2026.4.23. vulnerability
Weakness · CWE (1)
- CWE-697 Incorrect Comparison weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-9369 advisory
- https://github.com/NousResearch/hermes-agent/commit/09f85f2cf79362a2f7963754b49a44cb3d234176 web
- https://gist.github.com/YLChen-007/062b77ceac6aa9844842a616f5d2ef30 web
- https://github.com/NousResearch/hermes-agent package
- https://vuldb.com/submit/812230 web
- https://vuldb.com/vuln/365332 web
- https://vuldb.com/vuln/365332/cti web