GitHub Advisoryadvisory · PyPI
GHSA-cvf4-f829-762v pgAdmin is affected by an LDAP injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-12764
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-90
- Reviewed
- 2025-11-13
Affected packages
• PyPI pgadmin4: < 9.10 → fixed in 9.10
Description
pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.
Related
Alias · CVE (1)
- CVE-2025-12764 pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special… vulnerability
Weakness · CWE (1)
- CWE-90 Improper Neutralization of Special Elements used in an LDAP Query weakness