GitHub Advisoryadvisory · Packagist

GHSA-cvh5-p6r6-g2qc Exposed phpinfo() leadked via documentation files

MEDIUM Published 2021-08-30 Modified 2021-08-26 Official page ↗
Aliases
CVE-2021-37704
Ecosystem
Packagist
Packages
phpfastcache/phpfastcache
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
Weaknesses
CWE-200, CWE-668
Reviewed
2021-08-26

Affected packages

• Packagist phpfastcache/phpfastcache: < 6.1.5 → fixed in 6.1.5 • Packagist phpfastcache/phpfastcache: >= 7.0.0, < 7.1.2 → fixed in 7.1.2 • Packagist phpfastcache/phpfastcache: >= 8.0.0, < 8.0.7 → fixed in 8.0.7

Description

Impact The `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Patches Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will NOT be patched. Workarounds Protect the `/vendor` directory from public access. References The first issue revealing this vulnerability is located here: https://github.com/flextype/flextype/issues/567 V6 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/815 V7 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/814 V8 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/813 For more information If you have any questions or comments about this advisory: • Open an issue in our issue tracker • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2021-37704 PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-668 Exposure of Resource to Wrong Sphere weakness

References