GitHub Advisoryadvisory · PyPI

GHSA-cvhh-q5g5-qprp Keras framework vulnerable to deserialization of untrusted data

CRITICAL Published 2025-10-17 Modified 2026-10-27 Official page ↗
Aliases
CVE-2025-49655
Ecosystem
PyPI
Packages
keras
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-10-17

Affected packages

• PyPI keras: >= 3.11.0, < 3.11.3 → fixed in 3.11.3

Description

Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3, enabling a maliciously uploaded Keras file containing a TorchModuleWrapper class to run arbitrary code on an end user’s system when loaded despite safe mode being enabled. The vulnerability can be triggered through both local and remote files.

Related

Alias · CVE (1)

  • CVE-2025-49655 Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3,… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References