GitHub Advisoryadvisory · RubyGems

GHSA-cvp8-5r8g-fhvq omniauth-saml vulnerable to Improper Verification of Cryptographic Signature

CRITICAL Published 2024-09-11 Modified 2024-09-19 Official page ↗
Ecosystem
RubyGems
Packages
omniauth-saml
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-347
Reviewed
2024-09-11

Affected packages

• RubyGems omniauth-saml: >= 2.0.0, < 2.1.2 → fixed in 2.1.2 • RubyGems omniauth-saml: < 1.10.5 → fixed in 1.10.5 • RubyGems omniauth-saml: >= 2.2.0, < 2.2.1 → fixed in 2.2.1

Description

ruby-saml, the dependent SAML gem of omniauth-saml has a signature wrapping vulnerability in <= v1.12.0 and v1.13.0 to v1.16.0 , see https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2 As a result, omniauth-saml created a new release by upgrading ruby-saml to the patched versions v1.17.

Related

Weakness · CWE (1)

  • CWE-347 Improper Verification of Cryptographic Signature weakness

References