GitHub Advisoryadvisory · Packagist
GHSA-cw24-f6fq-7j9v Moodle allows teachers to evade trusttext config when restoring glossary entries
LOW
Official page ↗
- Aliases
- CVE-2025-26532
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-02-24
Affected packages
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.2 → fixed in 4.5.2
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.6 → fixed in 4.4.6
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.10 → fixed in 4.3.10
• Packagist moodle/moodle: < 4.1.16 → fixed in 4.1.16
Description
Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored.
Related
Alias · CVE (1)
- CVE-2025-26532 Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness