GitHub Advisoryadvisory · PyPI

GHSA-cw58-gpgw-hwx2 Plone allows weak passwords

HIGH Published 2022-05-24 Modified 2024-10-14 Official page ↗
Aliases
CVE-2020-7940
Ecosystem
PyPI
Packages
Plone
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-521
Reviewed
2023-07-12

Affected packages

• PyPI Plone: >= 4.3, < 4.3.20 → fixed in 4.3.20 • PyPI Plone: >= 5.0rc1, < 5.1.7 → fixed in 5.1.7 • PyPI Plone: >= 5.2.0, < 5.2.2 → fixed in 5.2.2

Description

Missing password strength checks on some forms in Plone 4.3 through 5.2.0 allow users to set weak passwords, leading to easier cracking.

Related

Alias · CVE (1)

  • CVE-2020-7940 Missing password strength checks on some forms in Plone 4.3 through 5.2.0 allow users to set weak passwords, leading to easier cracking. vulnerability

Weakness · CWE (1)

  • CWE-521 Weak Password Requirements weakness

References