GitHub Advisoryadvisory · NuGet

GHSA-cw98-9j8w-wxv9 .NET Denial of Service Vulnerability

HIGH Published 2022-10-21 Modified 2026-06-08 Official page ↗
Aliases
CVE-2022-24464
Ecosystem
NuGet
Packages
Microsoft.AspNetCore.App.Runtime.linux-arm, Microsoft.AspNetCore.App.Runtime.linux-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-x64, Microsoft.AspNetCore.App.Runtime.linux-x64, Microsoft.AspNetCore.App.Runtime.osx-x64, Microsoft.AspNetCore.App.Runtime.win-arm, Microsoft.AspNetCore.App.Runtime.win-arm64, Microsoft.AspNetCore.App.Runtime.win-x64, Microsoft.AspNetCore.App.Runtime.win-x86, Microsoft.AspNetCore.App.Runtime.linux-musl-arm, Microsoft.AspNetCore.App.Runtime.osx-arm64
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2022-10-21

Affected packages

• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 3.1.5, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 3.0.0, < 3.1.23 → fixed in 3.1.23 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 5.0.0, < 5.0.15 → fixed in 5.0.15 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 6.0.0, < 6.0.3 → fixed in 6.0.3 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 6.0.0, < 6.0.3 → fixed in 6.0.3

Description

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0, and .NET CORE 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. Microsoft is aware of a Denial of Service vulnerability, which exists in .NET 6.0, .NET 5.0, and .NET CORE 3.1 when parsing certain types of http form requests. Affected Software • Any .NET 6.0 application running on .NET 6.0.2 or lower • Any .NET 5.0 application running on .NET 5.0.14 or lower • Any .NET Core 3.1 application running on .NET Core 3.1.22 or lower Patches To fix the issue, please install the latest version of .NET 6.0 or .NET 5.0 or .NET Core 3.1.. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs. • If you're using .NET Core 6.0, you should download and install Runtime 6.0.3 or SDK 6.0.201 (for Visual Studio 2022 v17.1) from https://dotnet.microsoft.com/download/dotnet-core/6.0. • If you're using .NET 5.0, you should download and install Runtime 5.0.15 or SDK 5.0.406 (for Visual Studio 2019 v16.11) or SDK 5.0.212 (for Visual Studio 2011 v16.9) from https://dotnet.microsoft.com/download/dotnet-core/5.0. • If you're using .NET Core 3.1, you should download and install Runtime 3.1.23 or SDK 3.1.417 (for Visual Studio 2019 v16.7.26) from https://dotnet.microsoft.com/download/dotnet-core/5.0. .NET 6.0 and .NET 5.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates. .NET 6.0 and .NET 5.0 and, .NET Core 3.1 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates. Other Details • Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/212 • An Issue for this can be found at https://github.com/dotnet/aspnetcore/issues/40598 • MSRC details for this can be found at https://msrc.microsoft.com/update-guide/en-US/vulnerability/ CVE-2022-24464

Related

Alias · CVE (1)

  • CVE-2022-24464 .NET and Visual Studio Denial of Service Vulnerability vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References