GitHub Advisoryadvisory · Maven
GHSA-cwh9-f8m6-6r63 Jenkins Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2014-3681
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-08
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 1.566, < 1.583 → fixed in 1.583
• Maven org.jenkins-ci.main:jenkins-core: < 1.565.3 → fixed in 1.565.3
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2014-3681 Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3681 advisory
- https://access.redhat.com/errata/RHBA-2014:1630 web
- https://access.redhat.com/errata/RHSA-2016:0070 web
- https://access.redhat.com/security/cve/CVE-2014-3681 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1147766 web
- https://exchange.xforce.ibmcloud.com/vulnerabilities/96975 web
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01 web