GitHub Advisoryadvisory · Packagist
GHSA-cwhp-rqfr-8462 Moodle XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2020-1691
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-13
Affected packages
• Packagist moodle/moodle: >= 3.8, < 3.8.1 → fixed in 3.8.1
Description
In Moodle 3.8, messages required extra sanitizing before updating the conversation overview, to prevent the risk of stored cross-site scripting.
Related
Alias · CVE (1)
- CVE-2020-1691 In Moodle 3.8, messages required extra sanitizing before updating the conversation overview, to prevent the risk of stored cross-site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness