GitHub Advisoryadvisory · PyPI

GHSA-cx63-2mw6-8hw5 setuptools vulnerable to Command Injection via package URL

HIGH Published 2024-07-15 Modified 2025-11-04 Official page ↗
Aliases
CVE-2024-6345
Ecosystem
PyPI
Packages
setuptools
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-07-15

Affected packages

• PyPI setuptools: < 70.0.0 → fixed in 70.0.0

Description

A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.

Related

Alias · CVE (1)

  • CVE-2024-6345 A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References