GitHub Advisoryadvisory · PyPI

GHSA-cxjf-x6jp-p7mc opencv-contrib-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863

HIGH Published 2024-08-30 Modified 2024-08-30 Official page ↗
Ecosystem
PyPI
Packages
opencv-contrib-python
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-787
Reviewed
2024-08-30

Affected packages

• PyPI opencv-contrib-python: < 4.8.1.78 → fixed in 4.8.1.78

Description

opencv-contrib-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-contrib-python v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.

Related

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References