GitHub Advisoryadvisory · npm

GHSA-cxrh-j4jr-qwg3 undici Denial of Service attack via bad certificate data

LOW Published 2025-05-15 Modified 2026-02-06 Official page ↗
Aliases
CVE-2025-47279
Ecosystem
npm
Packages
undici
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-401
Reviewed
2025-05-15

Affected packages

• npm undici: < 5.29.0 → fixed in 5.29.0 • npm undici: >= 6.0.0, < 6.21.2 → fixed in 6.21.2 • npm undici: >= 7.0.0, < 7.5.0 → fixed in 7.5.0

Description

Impact Applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. Patches This has been patched in https://github.com/nodejs/undici/pull/4088. Workarounds If a webhook fails, avoid keep calling it repeatedly. References Reported as: https://github.com/nodejs/undici/issues/3895

Related

Alias · CVE (1)

  • CVE-2025-47279 Undici is an HTTP/1.1 client for Node.js. vulnerability

Weakness · CWE (1)

  • CWE-401 Missing Release of Memory after Effective Lifetime weakness

References