GitHub Advisoryadvisory · PyPI

GHSA-f248-v4qh-x2r6 Improper Certificate Validation in blackduck

HIGH Published 2021-04-20 Modified 2024-09-13 Official page ↗
Aliases
CVE-2020-27589
Ecosystem
PyPI
Packages
blackduck
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-295
Reviewed
2021-04-19

Affected packages

• PyPI blackduck: >= 0.0.25, < 0.0.53 → fixed in 0.0.53

Description

Synopsys hub-rest-api-python (aka blackduck on PyPI) version 0.0.25 - 0.0.52 does not validate SSL certificates in certain cases.

Related

Alias · CVE (1)

  • CVE-2020-27589 Synopsys hub-rest-api-python (aka blackduck on PyPI) version 0.0.25 - 0.0.52 does not validate SSL certificates in certain cases. vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References