GitHub Advisoryadvisory · npm

GHSA-f29h-pxvx-f335 eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

HIGH Published 2025-07-19 Modified 2026-01-22 Official page ↗
Aliases
CVE-2025-54313
Ecosystem
npm
Packages
eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall, got-fetch
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weaknesses
CWE-506
Reviewed
2025-07-21

Affected packages

• npm eslint-config-prettier: >= 8.10.1, < 8.10.2 → fixed in 8.10.2 • npm eslint-config-prettier: >= 9.1.1, < 9.1.2 → fixed in 9.1.2 • npm eslint-config-prettier: >= 10.1.6, < 10.1.8 → fixed in 10.1.8 • npm eslint-plugin-prettier: >= 4.2.2, < 4.2.4 → fixed in 4.2.4 • npm synckit: >= 0.11.9, < 0.11.10 → fixed in 0.11.10 • npm @pkgr/core: >= 0.2.8, < 0.2.9 → fixed in 0.2.9 • npm napi-postinstall: >= 0.3.1, < 0.3.2 → fixed in 0.3.2 • npm got-fetch: >= 5.1.11, < 6.0.0 → fixed in 6.0.0

Description

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Related

Alias · CVE (1)

  • CVE-2025-54313 eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. vulnerability

Weakness · CWE (1)

  • CWE-506 Embedded Malicious Code weakness

References