GitHub Advisoryadvisory · Packagist
GHSA-f2g3-3c6q-4478 Magento 2 Community Edition Incorrect Authorization
MEDIUM
Official page ↗
- Aliases
- CVE-2020-24401
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2023-07-13
Affected packages
• Packagist magento/community-edition: < 2.4.1 → fixed in 2.4.1
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect authorization vulnerability. A user can still access resources provisioned under their old role after an administrator removes the role or disables the user's account.
Related
Alias · CVE (1)
- CVE-2020-24401 Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect authorization vulnerability. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness