GitHub Advisoryadvisory · Maven
GHSA-f2j5-w76m-3rqh Jenkins Anchore Container Image Scanner Plugin vulnerable to cross site scripting
HIGH
Official page ↗
- Aliases
- CVE-2022-41225
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:anchore-container-scanner
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-23
Affected packages
• Maven org.jenkins-ci.plugins:anchore-container-scanner: < 1.0.25 → fixed in 1.0.25
Description
Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control API responses by Anchore engine.
Related
Alias · CVE (1)
- CVE-2022-41225 Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-41225 advisory
- https://github.com/jenkinsci/anchore-container-scanner-plugin/commit/1b1a62ab8ab86b409274e755860ab4e7fcc11800 web
- https://github.com/jenkinsci/anchore-container-scanner-plugin package
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2821 web