GitHub Advisoryadvisory · Packagist

GHSA-f2qx-66wf-wvvx phpseclib guardrails needed on OID length

HIGH Published 2026-05-08 Modified 2026-05-08 Official page ↗
Aliases
CVE-2024-27355
Ecosystem
Packagist
Packages
phpseclib/phpseclib
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2026-05-08

Affected packages

• Packagist phpseclib/phpseclib: >= 2.0.0, < 2.0.47 → fixed in 2.0.47 • Packagist phpseclib/phpseclib: >= 3.0.0, < 3.0.36 → fixed in 3.0.36 • Packagist phpseclib/phpseclib: >= 0.1.1, < 1.0.23 → fixed in 1.0.23

Description

Related

Alias · CVE (1)

  • CVE-2024-27355 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References