GitHub Advisoryadvisory · Packagist
GHSA-f3cj-mjqm-fhvj Drupal core is Vulnerable to Cross-Site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2026-6365
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-06-05
Affected packages
• Packagist drupal/core: >= 8.0.0, < 10.5.9 → fixed in 10.5.9
• Packagist drupal/core: >= 10.6.0, < 10.6.7 → fixed in 10.6.7
• Packagist drupal/core: >= 11.0.0, < 11.2.11 → fixed in 11.2.11
• Packagist drupal/core: >= 11.3.0, < 11.3.7 → fixed in 11.3.7
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).
This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.
Related
Alias · CVE (1)
- CVE-2026-6365 Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness