GitHub Advisoryadvisory · Packagist
GHSA-f3f3-5q5j-6v47 GeSHi vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2012-3522
- Ecosystem
- Packagist
- Packages
- geshi/geshi
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-14
Affected packages
• Packagist geshi/geshi: < 1.0.8.11 → fixed in 1.0.8.11
Description
Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2012-3522 Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-3522 advisory
- https://github.com/GeSHi/geshi-1.0 package
- https://lists.fedorahosted.org/archives/list/[email protected]/message/AE33KOZ42XXG6DSH5SNGOTC3NS7FWZ2I web
- https://lists.fedorahosted.org/archives/list/[email protected]/message/H2R65LEAIDK6I53IYGZWDCRETBYKNUKF web
- https://lists.fedorahosted.org/archives/list/[email protected]/message/JA5TA3T7AJXWM4QMI62LMGW62WZUULGB web
- http://sourceforge.net/p/geshi/code/2508 web
- http://www.openwall.com/lists/oss-security/2012/08/21/11 web