GitHub Advisoryadvisory · npm
GHSA-f3fg-mf2q-fj3f NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies
HIGH
Official page ↗
- Aliases
- CVE-2025-48947
- Ecosystem
- npm
- Packages
- @auth0/nextjs-auth0
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L
- Weaknesses
- CWE-525
- Reviewed
- 2025-06-04
Affected packages
• npm @auth0/nextjs-auth0: >= 4.0.1, < 4.6.1 → fixed in 4.6.1
Description
Overview
In Auth0 Next.js SDK versions 4.0.1 to 4.6.0, __session cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers.
Am I Affected?
You are affected by this vulnerability if you meet the following preconditions:
1. Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0,
2. Applications using CDN or edge caching that caches responses with the Set-Cookie header.
3. If the Cache-Control header is not properly set for sensitive responses.
Fix
Upgrade auth0/nextjs-auth0 to v4.6.1.
Related
Alias · CVE (1)
- CVE-2025-48947 The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. vulnerability
Weakness · CWE (1)
- CWE-525 Use of Web Browser Cache Containing Sensitive Information weakness