GitHub Advisoryadvisory · Maven

GHSA-f3jh-qvm4-mg39 Erroneous authentication pass in Spring Security

HIGH Published 2024-03-18 Modified 2025-02-13 Official page ↗
Aliases
CVE-2024-22257
Ecosystem
Maven
Packages
org.springframework.security:spring-security-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-287, CWE-862
Reviewed
2024-03-18

Affected packages

• Maven org.springframework.security:spring-security-core: < 5.7.12 → fixed in 5.7.12 • Maven org.springframework.security:spring-security-core: >= 5.8.0, < 5.8.11 → fixed in 5.8.11 • Maven org.springframework.security:spring-security-core: >= 6.0.0, < 6.1.8 → fixed in 6.1.8 • Maven org.springframework.security:spring-security-core: >= 6.2.0, < 6.2.3 → fixed in 6.2.3

Description

In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to 5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8, versions 6.2.x prior to 6.2.3, an application is possible vulnerable to broken access control when it directly uses the AuthenticatedVoter#vote passing a null Authentication parameter. Specifically, an application is vulnerable if: The application uses AuthenticatedVoter directly and a null authentication parameter is passed to it resulting in an erroneous true return value. An application is not vulnerable if any of the following is true: • The application does not use AuthenticatedVoter#vote directly. • The application does not pass null to AuthenticatedVoter#vote. Note that AuthenticatedVoter is deprecated since 5.8, use implementations of AuthorizationManager as a replacement.

Related

Alias · CVE (1)

  • CVE-2024-22257 In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to 5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8,… vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-862 Missing Authorization weakness

References