GitHub Advisoryadvisory · RubyGems
GHSA-f489-655r-x6gr smalruby and smalruby-editor vulnerable to OS Command Injection
CRITICAL
Official page ↗
- Aliases
- CVE-2017-2096
- Ecosystem
- RubyGems
- Packages
- smalruby-editor, smalruby
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2023-01-27
Affected packages
• RubyGems smalruby-editor: < 0.4.1 → fixed in 0.4.1
• RubyGems smalruby: < 0.1.11 → fixed in 0.1.11
Description
smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2017-2096 smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors. vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-2096 advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/smalruby/CVE-2017-2096.yml web
- https://github.com/smalruby/smalruby-editor package
- https://web.archive.org/web/20200227194312/http://www.securityfocus.com/bid/95775 web
- http://jvn.jp/en/jp/JVN50197114/index.html web
- http://smalruby.jp/blog/2017/01/14/smalruby-editor-0-4-1-has-been-released-english.html web