GitHub Advisoryadvisory · Packagist

GHSA-f4cr-3xmc-2wpm phpMyAdmin SQL injection vulnerability

HIGH Published 2022-05-24 Modified 2024-04-24 Official page ↗
Aliases
CVE-2020-10802
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2024-04-24

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.9.0, < 4.9.5 → fixed in 4.9.5 • Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.2 → fixed in 5.0.2

Description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

Related

Alias · CVE (1)

  • CVE-2020-10802 In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References