GitHub Advisoryadvisory · Maven
GHSA-f4gq-7hvf-fjm3 Stored XSS vulnerability in Jenkins RapidDeploy Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2170
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:rapiddeploy-jenkins
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-22
Affected packages
• Maven org.jenkins-ci.plugins:rapiddeploy-jenkins: < 4.2.1 → fixed in 4.2.1
Description
RapidDeploy Plugin 4.2 and earlier does not escape package names in its displayed table of packages obtained from a remote server. This results in a stored cross-site scripting (XSS) vulnerability exploitable by users able to configure jobs.
RapidDeploy Plugin 4.2.1 escapes package names.
Related
Alias · CVE (1)
- CVE-2020-2170 Jenkins RapidDeploy Plugin 4.2 and earlier does not escape package names in the table of packages obtained from a remote server, resulting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness