GitHub Advisoryadvisory · Maven

GHSA-f4qr-f4xx-hjxw OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information

HIGH Published 2022-08-12 Modified 2022-08-12 Official page ↗
Aliases
CVE-2022-35980
Ecosystem
Maven
Packages
org.opensearch.plugin:opensearch-security
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-612
Reviewed
2022-08-12

Affected packages

• Maven org.opensearch.plugin:opensearch-security: >= 2.0.0.0, < 2.2.0.0 → fixed in 2.2.0.0

Description

Impact Requests to an OpenSearch cluster configured with advanced access control features (document level security (DLS), field level security (FLS), and/or field masking) will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. Patches OpenSearch 2.2.0+ contains the fix for this issue. OpenSearch Security Plugin 2.2.0.0 is compatible with OpenSearch 2.2.0. Workarounds There is no recommended work around. References See pull request #1999 for additional details. For more information If you have any questions or comments about this advisory we ask that contact AWS/Amazon Security via our vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue.

Related

Alias · CVE (1)

  • CVE-2022-35980 OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. vulnerability

Weakness · CWE (1)

  • CWE-612 Improper Authorization of Index Containing Sensitive Information weakness

References