GitHub Advisoryadvisory · PyPI

GHSA-f4rr-5m7v-wxcw Type confusion leading to `CHECK`-failure based denial of service in TensorFlow

MEDIUM Published 2022-05-24 Modified 2022-06-06 Official page ↗
Aliases
CVE-2022-29209
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-843
Reviewed
2022-05-24

Affected packages

• PyPI tensorflow: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-cpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-gpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1

Description

Impact The macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Patches We have patched the issue in GitHub commit b917181c29b50cb83399ba41f4d938dc369109a1 (merging GitHub PR #55730). The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported externally via a GitHub issue.

Related

Alias · CVE (1)

  • CVE-2022-29209 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-843 Access of Resource Using Incompatible Type weakness

References