GitHub Advisoryadvisory · Maven
GHSA-f58c-gq56-vjjf Apache Tika has XXE vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2025-66516
- Ecosystem
- Maven
- Packages
- org.apache.tika:tika-core, org.apache.tika:tika-parsers, org.apache.tika:tika-parser-pdf-module
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Weaknesses
- CWE-611
- Reviewed
- 2025-12-05
Affected packages
• Maven org.apache.tika:tika-core: >= 1.13, < 3.2.2 → fixed in 3.2.2
• Maven org.apache.tika:tika-parsers: >= 1.13, < 2.0.0 → fixed in 2.0.0
• Maven org.apache.tika:tika-parser-pdf-module: >= 2.0.0, < 3.2.2 → fixed in 3.2.2
Description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.
This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways.
First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable.
Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Related
Alias · CVE (1)
- CVE-2025-66516 Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms… vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness