GitHub Advisoryadvisory · Maven

GHSA-f5q9-j9r2-34gq Apache Kylin vulnerable to Command injection by Useless configuration

HIGH Published 2022-12-30 Modified 2023-01-10 Official page ↗
Aliases
CVE-2022-43396
Ecosystem
Maven
Packages
org.apache.kylin:kylin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-184, CWE-77
Reviewed
2023-01-03

Affected packages

• Maven org.apache.kylin:kylin: >= 2.0.0, < 4.0.3 → fixed in 4.0.3

Description

In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the `kylin.engine.spark-cmd` parameter of `conf`.

Related

Alias · CVE (1)

  • CVE-2022-43396 In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. vulnerability

Weakness · CWE (2)

  • CWE-184 Incomplete List of Disallowed Inputs weakness
  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References