GitHub Advisoryadvisory · Packagist
GHSA-f624-8hfq-5fh3 TYPO3 Information Disclosure of Installed Extensions
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- typo3/cms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2024-06-07
Affected packages
• Packagist typo3/cms: >= 8.0.0, < 8.7.23 → fixed in 8.7.23
• Packagist typo3/cms: >= 9.0.0, < 9.5.4 → fixed in 9.5.4
Description
It has been discovered that mechanisms used for configuration of RequireJS package loading are susceptible to information disclosure. This way a potential attack can retrieve additional information about installed system and third party extensions.
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/TYPO3/typo3/commit/889ed77d2905d8b17afd31c723a23240c978823f web
- https://github.com/TYPO3/typo3/commit/c81cca9e419e7aaed551b9b9a8d012ba7bffb287 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/2019-01-22-1.yaml web
- https://github.com/TYPO3/typo3 package
- https://typo3.org/security/advisory/typo3-core-sa-2019-001 web