GitHub Advisoryadvisory · Maven
GHSA-f655-xhvm-cwp4 Cross-site Scripting in Jenkins GitLab Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-34777
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:gitlab-plugin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-07-12
Affected packages
• Maven org.jenkins-ci.plugins:gitlab-plugin: < 1.5.35 → fixed in 1.5.35
Description
Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of webhook-triggered builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. GitLab Plugin 1.5.35 does not show user-provided fields in the build cause of webhook-triggered builds.
GitLab Plugin 1.5.35 does not show user-provided fields in the build cause of webhook-triggered builds.
Related
Alias · CVE (1)
- CVE-2022-34777 Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of webhook-triggered builds,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness