GitHub Advisoryadvisory · PyPI

GHSA-f6f8-9mx6-9mx2 Django vulnerable to Denial of Service

HIGH Published 2024-07-10 Modified 2025-11-04 Official page ↗
Aliases
CVE-2024-39614
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-130, CWE-770
Reviewed
2024-07-10

Affected packages

• PyPI Django: >= 5.0, < 5.0.7 → fixed in 5.0.7 • PyPI Django: >= 4.2, < 4.2.14 → fixed in 4.2.14

Description

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. `get_supported_language_variant()` was subject to a potential denial-of-service attack when used with very long strings containing specific characters.

Related

Alias · CVE (1)

  • CVE-2024-39614 An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. vulnerability

Weakness · CWE (2)

  • CWE-130 Improper Handling of Length Parameter Inconsistency weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References