GitHub Advisoryadvisory · Packagist
GHSA-f6p5-76fp-m248 URL Rewrite vulnerability in multiple zendframework components
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- zendframework/zend-diactoros, zendframework/zend-feed, zendframework/zend-http
- Severity
- High
- Reviewed
- 2022-04-28
Affected packages
• Packagist zendframework/zend-diactoros: < 1.8.4 → fixed in 1.8.4
• Packagist zendframework/zend-feed: < 2.10.3 → fixed in 2.10.3
• Packagist zendframework/zend-http: < 2.8.1 → fixed in 2.8.1
Description
zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism.
When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.
References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-diactoros/ZF2018-01.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-feed/ZF2018-01.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-http/ZF2018-01.yaml web