GitHub Advisoryadvisory · Packagist

GHSA-f6rc-rh43-h8gr Zend Access Restriction Bypass

MEDIUM Published 2022-05-17 Modified 2024-04-23 Official page ↗
Aliases
CVE-2014-8088
Ecosystem
Packagist
Packages
zendframework/zendframework, zendframework/zendframework1
Severity
Moderate
Weaknesses
CWE-287
Reviewed
2024-04-23

Affected packages

• Packagist zendframework/zendframework: >= 2.0.0, < 2.0.99 → fixed in 2.0.99 • Packagist zendframework/zendframework: >= 2.1.0, < 2.1.99 → fixed in 2.1.99 • Packagist zendframework/zendframework: >= 2.2.0, < 2.2.8 → fixed in 2.2.8 • Packagist zendframework/zendframework: >= 2.3.0, < 2.3.3 → fixed in 2.3.3 • Packagist zendframework/zendframework1: >= 1.12.0, < 1.12.9 → fixed in 1.12.9

Description

The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.

Related

Alias · CVE (1)

  • CVE-2014-8088 The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References