GitHub Advisoryadvisory · PyPI

GHSA-f73w-4m7g-ch9x Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library

CRITICAL Published 2023-09-01 Modified 2025-02-20 Official page ↗
Aliases
CVE-2023-39631
Ecosystem
PyPI
Packages
langchain, numexpr
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-09-01

Affected packages

• PyPI langchain: < 0.0.308 → fixed in 0.0.308 • PyPI numexpr: < 2.8.5 → fixed in 2.8.5

Description

An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library. Patches: Released in v.0.0.308. numexpr dependency is optional for langchain.

Related

Alias · CVE (1)

  • CVE-2023-39631 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References