GitHub Advisoryadvisory · npm

GHSA-f7r3-p866-q9qr ircdkit vulnerable to Denial of Service due to unhandled connection end event

LOW Published 2019-06-03 Modified 2022-08-03 Official page ↗
Ecosystem
npm
Packages
ircdkit
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2019-06-03

Affected packages

• npm ircdkit: < 1.0.4 → fixed in 1.0.4

Description

Versions of `ircdkit` 1.0.3 and prior are vulnerable to a remote denial of service. Recommendation Upgrade to version 1.0.4.

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References