GitHub Advisoryadvisory · PyPI
GHSA-f83q-2cp7-qrjg untangle vulnerable to Improper Restriction of XML External Entity Reference
HIGH
Official page ↗
- Aliases
- CVE-2022-31471
- Ecosystem
- PyPI
- Packages
- untangle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-611
- Reviewed
- 2022-08-06
Affected packages
• PyPI untangle: < 1.2.1 → fixed in 1.2.1
Description
Description
untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts XML external entity references. By exploiting this vulnerability, a remote unauthenticated attacker may read the contents of local files.
Impact
An attacker may be able to read the contents of local files. This affects untangle versions up to and including 1.2.0
Patches
The problem has been fixed with version 1.2.1
Workarounds
None
References
https://jvn.jp/en/jp/JVN30454777/
For more information
If you have any questions or comments about this advisory:
• Open an issue
Related
Alias · CVE (1)
- CVE-2022-31471 untangle is a python library to convert XML data to python objects. vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://github.com/stchris/untangle/security/advisories/GHSA-f83q-2cp7-qrjg web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31471 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/untangle/PYSEC-2022-244.yaml web
- https://github.com/stchris/untangle package
- https://github.com/stchris/untangle/releases/tag/1.2.1 web
- https://jvn.jp/en/jp/JVN30454777 web