GitHub Advisoryadvisory · Packagist

GHSA-f884-gm86-cg3q PrestaShop module ps_facetedsearch might be vulnerable from CVE-2017-9841

HIGH Published 2020-01-07 Modified 2020-01-07 Official page ↗
Ecosystem
Packagist
Packages
prestashop/ps_facetedsearch
Severity
High
Reviewed
2020-01-07

Affected packages

• Packagist prestashop/ps_facetedsearch: < 3.4.1 → fixed in 3.4.1

Description

Impact We have identified that some ps_facetedsearch module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE. This vulnerability impacts • phpunit before 4.8.28 and 5.x before 5.6.3 as reported in CVE-2017-9841 • phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers) Patches In the security patch, we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading. Workarounds Users can also simply remove the unwanted vendor/phpunit folder. References https://nvd.nist.gov/vuln/detail/CVE-2017-9841 For more information If you have any questions or comments about this advisory, email us at [email protected]

References