GitHub Advisoryadvisory · Packagist
GHSA-f8fv-f786-9933 Magento improper input validation vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2022-24086
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
- Weaknesses
- CWE-20
- Reviewed
- 2024-01-11
Affected packages
• Packagist magento/community-edition: >= 2.3.3-p1, < 2.3.7-p3 → fixed in 2.3.7-p3
• Packagist magento/community-edition: >= 2.4.0, < 2.4.3-p2 → fixed in 2.4.3-p2
Description
Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.
Related
Alias · CVE (1)
- CVE-2022-24086 Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness