GitHub Advisoryadvisory · npm
GHSA-f8hv-rx9p-f9r4 generator-hottowel Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2016-15025
- Ecosystem
- npm
- Packages
- generator-hottowel
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-22
Affected packages
• npm generator-hottowel: < 0.5.0 → fixed in 0.5.0
Description
A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/_app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. The name of the patch is c17092fd4103143a9ddab93c8983ace8bf174396. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-221484.
Related
Alias · CVE (1)
- CVE-2016-15025 A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-15025 advisory
- https://github.com/johnpapa/generator-hottowel/pull/174 web
- https://github.com/johnpapa/generator-hottowel/commit/c17092fd4103143a9ddab93c8983ace8bf174396 web
- https://github.com/johnpapa/generator-hottowel package
- https://vuldb.com/?ctiid.221484 web
- https://vuldb.com/?id.221484 web