GitHub Advisoryadvisory · NuGet
GHSA-f8qx-mjcq-wfgx ASP.NET Core Denial of Service Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2020-1597
- Ecosystem
- NuGet
- Packages
- Microsoft.AspNetCore.App, Microsoft.AspNetCore.All, Microsoft.AspNetCore.App.Runtime.linux-arm, Microsoft.AspNetCore.App.Runtime.linux-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-x64, Microsoft.AspNetCore.App.Runtime.linux-x64, Microsoft.AspNetCore.App.Runtime.osx-x64, Microsoft.AspNetCore.App.Runtime.win-arm, Microsoft.AspNetCore.App.Runtime.win-arm64, Microsoft.AspNetCore.App.Runtime.win-x64, Microsoft.AspNetCore.App.Runtime.win-x86
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-10-24
Affected packages
• NuGet Microsoft.AspNetCore.App: >= 2.1.0, < 2.1.21 → fixed in 2.1.21
• NuGet Microsoft.AspNetCore.All: >= 2.1.0, < 2.1.21 → fixed in 2.1.21
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 3.1.0, < 3.1.7 → fixed in 3.1.7
Description
A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka `ASP.NET Core Denial of Service Vulnerability`.
Related
Alias · CVE (1)
- CVE-2020-1597 A denial of service vulnerability exists when ASP.NET Core improperly handles web requests. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-1597 advisory
- https://github.com/dotnet/announcements/issues/162 web
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WH5FQ5VT3JGHXFXOETHCTBWJUIAPGHHT web
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZW4CBI26KSO3PRL3HLVVISXPPOYUHSXO web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WH5FQ5VT3JGHXFXOETHCTBWJUIAPGHHT web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZW4CBI26KSO3PRL3HLVVISXPPOYUHSXO web
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-1597 web