GitHub Advisoryadvisory · Maven
GHSA-f8r6-6222-9pvc Apache Kyuubi Server vulnerable to Path Traversal
HIGH
Official page ↗
- Aliases
- CVE-2025-66518
- Ecosystem
- Maven
- Packages
- org.apache.kyuubi:kyuubi-server_2.12
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
- Weaknesses
- CWE-22, CWE-27
- Reviewed
- 2026-01-05
Affected packages
• Maven org.apache.kyuubi:kyuubi-server_2.12: >= 1.6.0, < 1.10.3 → fixed in 1.10.3
Description
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config.
This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2.
Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2025-66518 Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config… vulnerability